const regex = /(?<![\w)]\s\s|[\w)]\s|[\w)])((\{)(.*?)\})/ismg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![\\w)]\\s\\s|[\\w)]\\s|[\\w)])((\\{)(.*?)\\})', 'ismg')
const str = `
@media(max-width: 450px){
.est{
direction: ltr;}
}
{
color: red
}
a
{
color: red
}
{
color: red
}
{
color: red
}
a
{
color: red
}
a
{}
{}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}