re = /(?<![\w)]\s\s|[\w)]\s|[\w)])((\{)(.*?)\})/im
str = '
@media(max-width: 450px){
.est{
direction: ltr;}
}
{
color: red
}
a
{
color: red
}
{
color: red
}
{
color: red
}
a
{
color: red
}
a
{}
{}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end