$re = '/(?<![\w)]\s\s|[\w)]\s|[\w)])((\{)(.*?)\})/ism';
$str = '
@media(max-width: 450px){
.est{
direction: ltr;}
}
{
color: red
}
a
{
color: red
}
{
color: red
}
{
color: red
}
a
{
color: red
}
a
{}
{}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);