#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:(\w+) *\(?)?\b(\d+) ?x ?(\d+) ?(cm)\b"
Local $sString = "" & @CRLF & _
"30 x 30 cm" & @CRLF & _
"30x30cm" & @CRLF & _
"30x30 cm" & @CRLF & _
"Ixxx 30x30cm" & @CRLF & _
"xxxx (30x30cm)" & @CRLF & _
"xxxx (30 x 30 cm)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")