$re = '/(?:(\w+) *\(?)?\b(\d+) ?x ?(\d+) ?(cm)\b/';
$str = '
30 x 30 cm
30x30cm
30x30 cm
Ixxx 30x30cm
xxxx (30x30cm)
xxxx (30 x 30 cm)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);