import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(\\w+) *\\(?)?\\b(\\d+) ?x ?(\\d+) ?(cm)\\b";
final String string = "\n"
+ "30 x 30 cm\n"
+ "30x30cm\n"
+ "30x30 cm\n"
+ "Ixxx 30x30cm\n"
+ "xxxx (30x30cm)\n"
+ "xxxx (30 x 30 cm)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}