package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:1?\d{1,2}|2[0-4]\d|25[0-5])\.){3}(1?\d{1,2}|2[0-4]\d|25[0-5])\/(?:[0-9]|[1-2][0-9]|3[0-2])$`)
var str = `192.168.50.1/16
192.168.50.1/9
92.168.50.1/0
192.168.50.1/
0.0.0.0/0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}