re = /^(?:(?:1?\d{1,2}|2[0-4]\d|25[0-5])\.){3}(1?\d{1,2}|2[0-4]\d|25[0-5])\/(?:[0-9]|[1-2][0-9]|3[0-2])$/m
str = '192.168.50.1/16
192.168.50.1/9
92.168.50.1/0
192.168.50.1/
0.0.0.0/0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end