# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\\~]+(['"]))(.*?)\1/$2$3$2/g;t' <<< "//window[2]//header[@id=\'top\']/div[1]//a[1]
//window[2]//header[@id=\\'top\\']/div[1]//a[1]
//window[2]//header[@id=\\\'top\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\'top\\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\\'top\\\\\']/div[1]//a[1]
//window[2]//header[@id=~~~~~'top~~~~~']/div[1]//a[1]"