$re = '/([\\\\~]+([\'"]))(.*?)\1/';
$str = '//window[2]//header[@id=\\\'top\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\\'top\\\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\\\\'top\\\\\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\\\\\\'top\\\\\\\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\\\\\\\\'top\\\\\\\\\\\']/div[1]//a[1]
//window[2]//header[@id=~~~~~\'top~~~~~\']/div[1]//a[1]';
$subst = "$2$3$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;