use strict;
my $str = '//window[2]//header[@id=\\\'top\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\\'top\\\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\\\\'top\\\\\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\\\\\\'top\\\\\\\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\\\\\\\\'top\\\\\\\\\\\']/div[1]//a[1]
//window[2]//header[@id=~~~~~\'top~~~~~\']/div[1]//a[1]';
my $regex = qr/([\\~]+(['"]))(.*?)\1/p;
my $subst = '$2$3$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";