$re = '/\+?(\d?)[-\(\.]?(\d{3})[-\)\.\s]?(\d{3})[-\.\s]?\d{4}/m';
$str = '+1(845)664-2199
18456642199
8456642199
845.664.2199
1.845.664.2199
+18456642199
1(845)664-2199
(845)664-2199
845 664 2199
845-664-2199
1-845-664-2199
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);