const regex = /\b(?:(port)|(dpi)|(fb_height)|(fb_width))="\K\d+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:(port)|(dpi)|(fb_height)|(fb_width))="\\K\\d+', 'g')
const str = `bst.instance.red.port="5555"
bst.instance.red.dpi="240"
bst.instance.red.fb_height="900"
bst.instance.red.fb_width="1600"
bst.instance.red.first_boot="0"
bst.instance.redb.port="2000"
bst.instance.redb.dpi="120"
bst.instance.redb.fb_height="300"
bst.instance.redb.fb_width="800"
bst.instance.redb.first_boot="0"
bst.instance.redc.port="2000"
bst.instance.redc.dpi="120"
bst.instance.redc.fb_height="300"
bst.instance.redc.fb_width="800"
bst.instance.redc.first_boot="0"`;
const subst = `${1:+111}${2:+222}${3:+333}${4:+444}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);