const regex = /(?=.*?KeyWord2)KEYWORD1|(?<=KeyWord2.*?)KEYWORD1/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=.*?KeyWord2)KEYWORD1|(?<=KeyWord2.*?)KEYWORD1', 'gmi')
const str = `One KEYWORD1 before one Keyword2 here
One KeyWord2 before one KEYWORD1 here
One KEYWORD1 before Keyword2 then KEYWORD1 and KEYWORD1 here
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}