re = /(?=.*?KeyWord2)KEYWORD1|(?<=KeyWord2.*?)KEYWORD1/mi
str = 'One KEYWORD1 before one Keyword2 here
One KeyWord2 before one KEYWORD1 here
One KEYWORD1 before Keyword2 then KEYWORD1 and KEYWORD1 here
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end