use strict;
my $str = 'One KEYWORD1 before one Keyword2 here
One KeyWord2 before one KEYWORD1 here
One KEYWORD1 before Keyword2 then KEYWORD1 and KEYWORD1 here
';
my $regex = qr/(?=.*?KeyWord2)KEYWORD1|(?<=KeyWord2.*?)KEYWORD1/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}