package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\.\b`)
var str = `h.e.ll.o w.o.r.l.d
=> hello world
h.e.ll.o w.o.r.l.d
=> hello world
hello. world
=> hello. world`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}