re = /\b\.\b/m
str = 'h.e.ll.o w.o.r.l.d
=> hello world
h.e.ll.o w.o.r.l.d
=> hello world
hello. world
=> hello. world'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end