$re = '/\b\.\b/m';
$str = 'h.e.ll.o w.o.r.l.d
=> hello world
h.e.ll.o w.o.r.l.d
=> hello world
hello. world
=> hello. world';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);