package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([1-9][0-9]{0,8})|([12][01][0-4][0-7][0-4][0-8][0-3][0-6][0-4][0-7])`)
var str = `4809238
1
2147483647`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}