use strict;
my $str = '4809238
1
2147483647';
my $regex = qr/([1-9][0-9]{0,8})|([12][01][0-4][0-7][0-4][0-8][0-3][0-6][0-4][0-7])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}