re = /([1-9][0-9]{0,8})|([12][01][0-4][0-7][0-4][0-8][0-3][0-6][0-4][0-7])/m
str = '4809238
1
2147483647'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end