const regex = /\/tmp\/test-raj\/([^\/]+)\/.+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/tmp\\\/test-raj\\\/([^\\\/]+)\\\/.+', 'gm')
const str = `/tmp/test-raj/abc/bcd.log
/tmp/test-raj/xyz/cccc.log
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}