import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\A#match|\\G(?!\\A))\\s*\\K^(# .+)\\n([\\s\\S]+?)(?=\\n# |\\Z)";
final String string = "#match\n\n"
+ "# Heading 1\n"
+ "Text of Heading 1\n"
+ "# Heading 2\n"
+ "Text of Heading 2\n"
+ "# Heading 3\n"
+ "Text of Heading 3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}