re = /(?:\A#match|\G(?!\A))\s*\K^(# .+)\n([\s\S]+?)(?=\n# |\Z)/m
str = '#match
# Heading 1
Text of Heading 1
# Heading 2
Text of Heading 2
# Heading 3
Text of Heading 3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end