import re
regex = re.compile(r"(?:\A#match|\G(?!\A))\s*\K^(# .+)\n([\s\S]+?)(?=\n# |\Z)", flags=re.MULTILINE)
test_str = ("#match\n\n"
"# Heading 1\n"
"Text of Heading 1\n"
"# Heading 2\n"
"Text of Heading 2\n"
"# Heading 3\n"
"Text of Heading 3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")