#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}"
Local $sString = "fdgjdfhg5.152.207.50 " & @CRLF & _
"193.9.113.164dfgdfg " & @CRLF & _
"dfgdgdf 193.9.113.165"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")