$re = '/\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}/m';
$str = 'fdgjdfhg5.152.207.50
193.9.113.164dfgdfg
dfgdgdf 193.9.113.165';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);