using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}";
string input = @"fdgjdfhg5.152.207.50
193.9.113.164dfgdfg
dfgdgdf 193.9.113.165";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}