#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Aug\s+[0-9]+:[0-9]+\s+(.+$)"
Local $sString = "Aug 15:07 file1.txt" & @CRLF & _
"Jul 15:04 file2.txt" & @CRLF & _
"Aug 15:05 file3.txt" & @CRLF & _
"Aug 15:05 file4.txt" & @CRLF & _
"Aug 2016 file5.txt" & @CRLF & _
"Jul 15:09 file6.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")