$re = '/^Aug\s+[0-9]+:[0-9]+\s+(.+$)/m';
$str = 'Aug 15:07 file1.txt
Jul 15:04 file2.txt
Aug 15:05 file3.txt
Aug 15:05 file4.txt
Aug 2016 file5.txt
Jul 15:09 file6.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);