import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Aug\\s+[0-9]+:[0-9]+\\s+(.+$)";
final String string = "Aug 15:07 file1.txt\n"
+ "Jul 15:04 file2.txt\n"
+ "Aug 15:05 file3.txt\n"
+ "Aug 15:05 file4.txt\n"
+ "Aug 2016 file5.txt\n"
+ "Jul 15:09 file6.txt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}