$re = '/.*(Priority:\s[34]).*/m';
$str = 'Incident Assigned: ID: [IR244691] Priority: 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);