re = /.*(Priority:\s[34]).*/m
str = 'Incident Assigned: ID: [IR244691] Priority: 3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end