import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^master$|^\\d+(?:(?:\\.\\d+)+|(?:\\-[A-z]+))+$";
final String string = "1.82.3-beta\n"
+ "master\n"
+ "21\n"
+ "12-hello-people\n"
+ "12-h3llo-people\n"
+ "1.12-alpha\n"
+ "1..2.3\n"
+ "1.2.3\n"
+ "alpha\n"
+ "beta\n"
+ "jklkkm\n"
+ "2-3-1-3\n"
+ "ew-234-sdads\n"
+ "2-h212332\n"
+ "2-212332\n"
+ "123-excellent\n"
+ "12-ExCelLenT";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}