use strict;
my $str = '1.82.3-beta
master
21
12-hello-people
12-h3llo-people
1.12-alpha
1..2.3
1.2.3
alpha
beta
jklkkm
2-3-1-3
ew-234-sdads
2-h212332
2-212332
123-excellent
12-ExCelLenT';
my $regex = qr/^master$|^\d+(?:(?:\.\d+)+|(?:\-[A-z]+))+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}