import re
regex = re.compile(r"^master$|^\d+(?:(?:\.\d+)+|(?:\-[A-z]+))+$", flags=re.MULTILINE)
test_str = ("1.82.3-beta\n"
"master\n"
"21\n"
"12-hello-people\n"
"12-h3llo-people\n"
"1.12-alpha\n"
"1..2.3\n"
"1.2.3\n"
"alpha\n"
"beta\n"
"jklkkm\n"
"2-3-1-3\n"
"ew-234-sdads\n"
"2-h212332\n"
"2-212332\n"
"123-excellent\n"
"12-ExCelLenT")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")