package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\/api\/.*`)
var str = `
https://example.com/api/does/match/
https://example.com/should/not/match/`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}