const regex = /.*\/api\/.*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\\/api\\\/.*', '')
const str = `
https://example.com/api/does/match/
https://example.com/should/not/match/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}