using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\+1(?<area_code>\d{3})(?<prefix>\d{3})(?<suffix>\d{4})";
string input = @"+12223334444";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}