$re = '/\+1(?<area_code>\d{3})(?<prefix>\d{3})(?<suffix>\d{4})/';
$str = '+12223334444';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);