re = /\+1(?<area_code>\d{3})(?<prefix>\d{3})(?<suffix>\d{4})/
str = '+12223334444'
# Print the match result
str.match(re) do |match|
puts match.to_s
end