const regex = /<(?:div|ul|li)(?=[^>]*\bclass="([^"]+)")(?=(?:[^>]*\bdata-\w+="([^"]+)")?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(?:div|ul|li)(?=[^>]*\\bclass="([^"]+)")(?=(?:[^>]*\\bdata-\\w+="([^"]+)")?)', 'gm')
const str = `With preg_match_all I want to get class and data-attributes in html.
I asked a similar question before. The correct answer to the previous responsibility was done with DOM. But as an alternative to the DOM structure, I also need a regex version.
The pattern works fine. However, if the lines are side-by-side, they also take class names from tags that should not be accepted.
<div class="noproblem">
<ul class="noproblem" data-ss="1">
<li class="noproblem" data-ss="1">
<!-- <i> is not my tag. but there s no problem with that. because it s underneath . -->
<i class="no_problem"></i>
</li>
</ul>
</div>
<div class="noproblem" data-ss="1"> <!-- problem: data-ss is not accepted -->
<ul class="noproblem" data-ss="1">
<!-- <i> is not my tag. my tags: div|ul|li . -->
<li class="noproblem"><i class="this_is_problem"></i>
</li>
</ul>
</div>
<div class="noproblem">
<ul class="noproblem">
<!-- <i> is not my tag. my tags: div|ul|li . -->
<li class="noproblem"><i class="this_is_problem"></i>
</li>
<!-- <span> is not my tag. my tags: div|ul|li . -->
<li class="test"><span class="this_is_problem"></span></li>
<!-- (li class empty version): <span> is not my tag. my tags: div|ul|li . -->
<li><span class="this_is_problem"></span></li>
</ul>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}