import Foundation
let pattern = #"<(?:div|ul|li)(?=[^>]*\bclass="([^"]+)")(?=(?:[^>]*\bdata-\w+="([^"]+)")?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
With preg_match_all I want to get class and data-attributes in html.
I asked a similar question before. The correct answer to the previous responsibility was done with DOM. But as an alternative to the DOM structure, I also need a regex version.
The pattern works fine. However, if the lines are side-by-side, they also take class names from tags that should not be accepted.
<div class="noproblem">
<ul class="noproblem" data-ss="1">
<li class="noproblem" data-ss="1">
<!-- <i> is not my tag. but there s no problem with that. because it s underneath . -->
<i class="no_problem"></i>
</li>
</ul>
</div>
<div class="noproblem" data-ss="1"> <!-- problem: data-ss is not accepted -->
<ul class="noproblem" data-ss="1">
<!-- <i> is not my tag. my tags: div|ul|li . -->
<li class="noproblem"><i class="this_is_problem"></i>
</li>
</ul>
</div>
<div class="noproblem">
<ul class="noproblem">
<!-- <i> is not my tag. my tags: div|ul|li . -->
<li class="noproblem"><i class="this_is_problem"></i>
</li>
<!-- <span> is not my tag. my tags: div|ul|li . -->
<li class="test"><span class="this_is_problem"></span></li>
<!-- (li class empty version): <span> is not my tag. my tags: div|ul|li . -->
<li><span class="this_is_problem"></span></li>
</ul>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)