use strict;
my $str = 'With preg_match_all I want to get class and data-attributes in html.
I asked a similar question before. The correct answer to the previous responsibility was done with DOM. But as an alternative to the DOM structure, I also need a regex version.
The pattern works fine. However, if the lines are side-by-side, they also take class names from tags that should not be accepted.
<div class="noproblem">
<ul class="noproblem" data-ss="1">
<li class="noproblem" data-ss="1">
<!-- <i> is not my tag. but there s no problem with that. because it s underneath . -->
<i class="no_problem"></i>
</li>
</ul>
</div>
<div class="noproblem" data-ss="1"> <!-- problem: data-ss is not accepted -->
<ul class="noproblem" data-ss="1">
<!-- <i> is not my tag. my tags: div|ul|li . -->
<li class="noproblem"><i class="this_is_problem"></i>
</li>
</ul>
</div>
<div class="noproblem">
<ul class="noproblem">
<!-- <i> is not my tag. my tags: div|ul|li . -->
<li class="noproblem"><i class="this_is_problem"></i>
</li>
<!-- <span> is not my tag. my tags: div|ul|li . -->
<li class="test"><span class="this_is_problem"></span></li>
<!-- (li class empty version): <span> is not my tag. my tags: div|ul|li . -->
<li><span class="this_is_problem"></span></li>
</ul>
</div>';
my $regex = qr/<(?:div|ul|li)(?=[^>]*\bclass="([^"]+)")(?=(?:[^>]*\bdata-\w+="([^"]+)")?)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}