const regex = new RegExp('\\G-', 'gm')
const str = `---Three dashes a-b-c-d`;
const subst = `- `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);