use strict;
my $str = '---Three dashes a-b-c-d';
my $regex = qr/\G-/mp;
my $subst = '- ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";