$re = '/\G-/m';
$str = '---Three dashes a-b-c-d';
$subst = "- ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;