package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mU)\-[0-9]+$`)
var str = `mydomain/mypost-2
http://mydomain/mypost-2
http://mydomain/mypost-234
mydomain/mypost-24`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}