// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mU)\-[0-9]+$").unwrap();
let string = "mydomain/mypost-2
http://mydomain/mypost-2
http://mydomain/mypost-234
mydomain/mypost-24";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}